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Statistics 202: Statistical Aspects of Data Mining

Professor David Mease

Tuesday, Thursday 9:00-10:15 AM Terman 156

Lecture 6 =  More of chapter 3

Agenda:
1) Announce midterm exam (Thursday, July 26)
2) Lecture over more of chapter 3 

(sections 3.3 and 3.2)
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Announcement – Midterm Exam:
The midterm exam will be Thursday, July 26

The best thing will be to take it in the classroom 
(9:00-10:15 AM in Terman 156)

For remote students who absolutely can not come to 
the classroom that day please email me to confirm 
arrangements with SCPD

You are allowed one 8.5 x 11 inch sheet (front and 
back) for notes

No books or computers are allowed, but please 
bring a hand held calculator

The exam will cover the material that we covered   
in class from Chapters 1,2,3 and 6
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Homework Assignment:

Chapter 3 Homework Part 1 is due Tuesday 7/17

Either email to me (dmease@stanford.edu), bring it to 
class, or put it under my office door.  

SCPD students may use email or fax or mail.

The assignment is posted at 

http://www.stats202.com/homework.html
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Introduction to Data Mining

by
Tan, Steinbach, Kumar

Chapter 3: Exploring Data
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Exploring Data

We can explore data visually (using tables or graphs) 
or numerically (using summary statistics)

Section 3.2 deals with summary statistics

Section 3.3 deals with visualization

We will begin with visualization

Note that many of the techniques you use to explore 
data are also useful for presenting data 
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Boxplots (Pages 114-115)
Invented by J. Tukey

A simple summary of the distribution of the data

Boxplots are useful for comparing distributions of 
multiple attributes or the same attribute for different 
groups

outlier
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90th percentile
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Boxplots in R

The function boxplot() in R plots boxplots

By default, boxplot() in R plots the maximum and the 
minimum (if they are not outliers) instead of the 10th

and 90th percentiles as the book describes

outlier
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75th percentile

50th percentile

90th percentile Maximum

Minimum
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Boxplots (Pages 114-115)
Boxplots help you visualize the differences in the 

medians relative to the variation 

Example: The median value of Attribute A was 2.0 for 
men and 4.1 for women.  Is this a “big” difference?
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Boxplots (Pages 114-115)
Boxplots help you visualize the differences in the 

medians relative to the variation 

Example: The median value of Attribute A was 2.0 for 
men and 4.1 for women.  Is this a “big” difference?

Maybe yes:
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Boxplots (Pages 114-115)
Boxplots help you visualize the differences in the 

medians relative to the variation 

Example: The median value of Attribute A was 2.0 for 
men and 4.1 for women.  Is this a “big” difference?

Maybe yes: Maybe no:
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In class exercise #16:
Use boxplot() in R to make boxplots comparing the first 
and second exam scores in the data at
www.stats202.com/exams_and_names.csv
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In class exercise #16:
Use boxplot() in R to make boxplots comparing the first 
and second exam scores in the data at
www.stats202.com/exams_and_names.csv

Answer:

data<-read.csv("exams_and_names.csv")

boxplot(data[,2],data[,3],col="blue",
main="Exam Scores",
names=c("Exam 1","Exam 2"),ylab="Exam Score")
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In class exercise #16:
Use boxplot() in R to make boxplots comparing the first 
and second exam scores in the data at
www.stats202.com/exams_and_names.csv

Answer:
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Visualization in Excel

Up until now, we have done all the visualization in R

Excel also can make many different types of graphs.  
They are found under the “Insert” menu by selecting 
“Chart”

When using Excel to make graphs which anyone will 
see other than yourself, I strongly encourage you to 
change defaults such as the grey background.

Excel also has a nice tool for making tables and 
associated graphs called “PivotTable and PivotChart 
Report” under the “Data” menu. 
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In class exercise #17:
Use “Insert” > “Chart” > “XY Scatter” to make a scatter 
plot of the exam scores at 
www.stats202.com/exams_and_names.csv
Put Exam 1 on the X axis and Exam 2 on the Y axis.
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In class exercise #17:
Use “Insert” > “Chart” > “XY Scatter” to make a scatter 
plot of the exam scores at 
www.stats202.com/exams_and_names.csv
Put Exam 1 on the X axis and Exam 2 on the Y axis.

Answer: Exam Scores
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In class exercise #18:
The data www.stats202.com/more_stats202_logs.txt
contains access logs from May 7, 2007 to July 1, 2007.
Use “Data” > “PivotTable and PivotChart Report” In Excel 
to make a table with the counts of 
GET /lecture2=start-chapter-2.ppt HTTP/1.1
and
GET /lecture2=start-chapter-2.pdf HTTP/1.1
for each date.  Which is more popular?
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In class exercise #18:
The data www.stats202.com/more_stats202_logs.txt
contains access logs from May 7, 2007 to July 1, 2007.
Use “Data” > “PivotTable and PivotChart Report” In Excel 
to make a table with the counts of 
GET /lecture2=start-chapter-2.ppt HTTP/1.1
and
GET /lecture2=start-chapter-2.pdf HTTP/1.1
for each date.  Which is more popular?

Answer:

Date GET /lecture2=start-chapter-2.pdf HTTP/1.1 GET /lecture2=start-chapter-2.ppt HTTP/1.1 Grand Total
27-Jun-07 150 17 167
28-Jun-07 247 29 276
29-Jun-07 253 53 306
30-Jun-07 77 9 86
1-Jul-07 50 7 57
Grand Total 777 115 892
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In class exercise #19:
The data www.stats202.com/more_stats202_logs.txt
contains access logs from May 7, 2007 to July 1, 2007.
Use “Data” > “PivotTable and PivotChart Report” In Excel 
to make a table with the counts of the rows for each 
date in May.
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In class exercise #19:
The data www.stats202.com/more_stats202_logs.txt
contains access logs from May 7, 2007 to July 1, 2007.
Use “Data” > “PivotTable and PivotChart Report” In Excel 
to make a table with the counts of the rows for each 
date in May.

Answer:
Date Count
May-7 88
May-8 88
May-9 65
May-10 179
May-11 47
May-12 67
May-13 47
May-14 59
May-15 58
May-16 107
May-17 64
May-18 93
May-19 66
May-20 104
May-21 123
May-22 75
May-23 85
May-24 81
May-25 49
May-26 60
May-27 78
May-28 66
May-29 64
May-30 69
May-31 46
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In class exercise #20:
Use “Insert” > “Chart” > “Line” In Excel to make a graph 
on the number of rows versus the date for the previous 
exercise.



22

In class exercise #20:
Use “Insert” > “Chart” > “Line” In Excel to make a graph 
on the number of rows versus the date for the previous 
exercise.

Answer: Stats 202 Logs
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Using Color in Plots
In R, the graphing parameter “col” can often be used 

to specify different colors for points, lines etc.

Some advantages of color:

- provides a nice way to differentiate

- makes it more interesting to look at

Some disadvantages of color:

- Some people are color blind

- Most printing is in black and white

- Color can be distracting

- A poor color scheme can make the graph difficult 
to read (example: yellow lines in Excel)
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3-Dimesional Plots
3D plots can sometimes be useful

One example is the 3D scatter plot for plotting 3 
attributes (page 119)

The function scatterplot3d() makes fairly nice 3D 
scatter plots in R 

-this is not in the base package so you need to do:
install.packages("scatterplot3d")
library(scatterplot3d) 

However, it may be better to show the 3rd dimension by 
simply using a 2D plot with different plotting characters 
(page 119)
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3-Dimesional Plots
Never use the 3rd dimension in a manner that conveys 

no extra information just to make the plot look more 
impressive
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3-Dimesional Plots
Never use the 3rd dimension in a manner that conveys 

no extra information just to make the plot look more 
impressive

Examples:

http://www.jpowered.com/graph_chart_collection/download.htm
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In class exercise #21:
Not only does the 3rd dimension fail to provide any 
information in the previous two examples, but it can 
also distort the truth.  How?
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Do’s and Don’ts (Page 130)

Read the ACCENT Principles

Read Tufte’s Guidelines
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Compressing Vertical Axis

Good Presentation
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No Zero Point On Vertical Axis
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No Relative Basis

Good Presentation
A’s received by 

students.
A’s received by

students.

Bad Presentation
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Chart Junk
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Final Touches
Many times plots are difficult to read or unattractive 

because people do not take the time to learn how to 
adjust default values for font size, font type, color 
schemes, margin size, plotting characters, etc.

In R, the function par() controls a lot of these

Also in R, the command expression() can produce 
subscripts and Greek letters in the text

-example: xlab=expression(alpha[1])

In Excel, it is often difficult to get exactly what you 
want, but you can usually improve upon the default 
values
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Exploring Data

We can explore data visually (using tables or graphs) 
or numerically (using summary statistics)

Section 3.2 deals with summary statistics

Section 3.3 deals with visualization

We will begin with visualization

Note that many of the techniques you use to explore 
data are also useful for presenting data 

http://images.google.com/imgres?imgurl=http://www.gesat.cc/images/CheckMark.jpg&imgrefurl=http://www.gesat.cc/images/&h=442&w=400&sz=17&tbnid=7_utCuEW791POM:&tbnh=127&tbnw=115&prev=/images%3Fq%3Dcheck%2Bmark%26um%3D1&start=1&sa=X&oi=images&ct=image&cd=1
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Summary Statistics (Section 3.2, Page 98):
You should be familiar with the following elementary 

summary statistics:

-Measures of Location: Percentiles (page 100)

Mean (page 101)

Median (page 101)

-Measures of Spread: Range (page 102)

Variance (page 103)

Standard Deviation (page 103)

Interquartile Range (page 103)

-Measures of 

Association: Covariance (page 104)

Correlation (page 104)
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Measures of Location

Terminology: the “mean” is the average

Terminology: the “median” is the 50th percentile

Your book classifies only the mean and median as 
measures of location but not percentiles

More commonly, all three are thought of as measures 
of location and the mean and median are more 
specifically measures of center

Terminology: the 1st, 2nd and 3rd quartiles are the 25th, 
50th and 75th percentiles respectively
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Mean vs. Median
While both are measures of center, the median is 

sometimes preferred over the mean because it is more 
robust to outliers (=extreme observations) and skewness

If the data is right-skewed, the mean will be greater 
than the median

If the data is left-skewed, the mean will be smaller  
than the median

If the data is symmetric, the mean will be equal to the 
median
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Measures of Spread:
The range is the maximum minus the minimum.  This 

is not robust and is extremely sensitive to outliers.

The variance is

where n is the sample size and     is the sample mean.  
This is also not very robust to outliers.

The standard deviation is simply the square root of 
the variance.  It is on the scale of the original data.  It is 
roughly the average distance from the mean.

The interquartile range is the 3rd quartile minus the 
1st quartile.  This is quite robust to outliers.
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In class exercise #22:
Compute the standard deviation for this data by hand:

2 10 22 43 18

Confirm that R and Excel give the same values.
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Measures of Association:
The covariance between x and y is defined as

where     is the mean of x and     is the mean of y and n
is the sample size.  This will be positive if x and y have a 
positive relationship and negative if they have a 
negative relationship.

The correlation is the covariance divided by the 
product of the two standard deviations.  It will be 
between -1 and +1 inclusive.  It is often denoted r.  It is 
sometimes called the coefficient of correlation.

These are both very sensitive to outliers.
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Correlation (r):
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In class exercise #23:
Match each plot with its correct coefficient of correlation.

Choices: r=-3.20, r=-0.98, r=0.86, r=0.95, 
r=1.20, r=-0.96, r=-0.40
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In class exercise #24:
Make two vectors of length 1,000,000 in R using 
runif(1000000) and compute the coefficient of 
correlation using cor().  Does the resulting value 
surprise you?
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In class exercise #25:
What value of r would you expect for the two exam 
scores in www.stats202.com/exams_and_names.csv
which are plotted below.  Compute the value to check 
your intuition.
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